Geophysical Computing L18-1

L18 - Finalizing Illustrations for Publication

1. Preparing Figures for Publication

Now that you’ve spent a ton of time generating wonderful graphics of your research
material let’s discuss how do we ultimately format these graphics to be published in a
research journal. After all, we’ve spent a lot of time and effort in doing our research and
making our plots, we should spend a little bit of time to make them really pop in the
journal article. | am a strong advocate of cleaning up all figures using Adobe
Illustrator. The primary reason is that: We can spend a long time in programs like GMT
or MATLAB trying to make every color and every line and every piece of text perfect.
Or, we can spend a smaller amount of time in GMT perfecting line thicknesses and
quickly edit everything in Illustrator to look perfect!

In what follows we will first describe some basics about preparing images for publication
and then do a short tutorial on Adobe Illustrator.

2. Figure Basics

Before preparing your finalized figures you should always check the journals web page for figure
guidelines. For example, the Journal of Geophysical Research (JGR) is one of the most
common journals you may submit your work to. Searching their website one finds a guide for

authors and in particular a guide for preparing figures:

http://www.agu.org/pubs/authors/manuscript _tools/journals/graphics prep.shtml

The guidelines given on this page are similar for all journals. Here are the most important points
we should adhere to when considering figure design for all journals:

e For most graphics use the Encapsulated Postscript (.eps) file format.

e For photographic images or raster graphics use Tagged Image File Format (.tiff) file
format. The JGR explanation here is nice:

"TIFF provides the highest resolution to ensure patterns and shading are maintained, yet
it offers lossless compression and thus smaller file size.”

o All lines must be at least 0.5 point thickness.

e Do not use font sizes less than 8 points. In general use 12 point font for figure labels and
no less than 10 point font for axis labels. Only use 8 point font as a last resort if it is just
impossible to fit text with 10 point font into the figure.

e Use a standard font such as Times New Roman or Helvetica.

e Combine multi-part plates or figures into a single figure adding letter labels for the
individual plates. For example,
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X-axis Label (12 point font)

e Always determine the allowable figure size (e.g., a single column figure is typically 8.5
cm in width) and scale your figure into the allowable size. Then adjust all fonts and line
weights, etc.

3. Adobe lllustrator Cookbook

What we are going to do here is use Adobe Illustrator to take two raw figures generated in
MATLAB and prepare them such that they are suitable for publication.

First, go to the course webpage and download the material for L18. The files we will be working
with here are called: ce_ex_new_hv.eps and res_ex_new_hv.eps. Then launch Adobe
Ilustrator on the PC side of the computers.

Both space and color cost money (depending on the journal color figures can cost you thousands
of dollars) so our goal here is to make a figure combining both plots above that is (1) in black &
white, and (2) only spans 1-column. As we go along be sure to save your figure often (in .eps
format so that you don’t lose any changes you made due to unforeseen problems).

Step 1) Open Files in Hlustrator. First of all, right click on each file and select: Open With -
Adobe lllustrator. Select one of the images on one plot and copy it into the other window such
that both figures are on the same plot. You should have a window that looks something like:
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Step 2) Create Figure bounding box and roughly scale figures.

In this example we want to create a single column figure. In general column sizes are 8.5 cm (but
may vary depending on journal). So, we will create a box to overlay our figure inside of that is

8.5 cm wide to give us a guide as to how to scale our figure.

o Create a new layer to place the bounding box on. Find the Layers box (Select Window
- Layers if it isn’t visible on your screen) and hit the Create New Layer button.
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Select this new layer so that we are working on it.
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e We want to create a box that is 8.5 cm wide. So, let’s make sure our units are in cm.
Select File > Document Setup... and change the Units to Centimeters.

e Now select the Rectangle Tool and click somewhere on the drawing to create a box. Just
clicking on the plot allows us to directly enter the box size.

I
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Cancel |
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¢ Now place this rectangle in the center of the drawing board. Select both figures (Use the

selection tool EI and holding Shift to select more than one object) and scale them
down evenly (Hold Shift while dragging on the corners of the box).
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Step 3) Axis labels and axis tick marks. The figure now looks dramatically different than
before in terms of how thick the lines are and how big the axis labels are. Just remember, this is
what the journal would do to your figure if you give them a full size plot. So, if you don’t want
your final journal figures to look like crap then you see the importance of what we are doing. So,
now it is time to adjust the font size of our axes.

Zoom into the drawing by either using the Zoom Tool S or pressing Ctrl and + at the
same time.

Select each of the figures and ungroup all of the objects: Object - Ungroup

Now select one of the axis labels. E.g., here | select one of the X-axis labels. Using the
Character Window change the Font size to 12 pt and the font type to Times New Roman:
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I don’t like that Hertz is all capitalized so | want to change HZ to Hz. Use the Type Tool
1. and change the text.

Frequency (Hz)

Now go ahead and edit all of the axis labels (Frequency and Ellipticity) making them 12
point font, and the labels on the tick marks (e.g., 0, 2, 4, 6, etc.) making them 10 point
font. You may want to delete every other Ellipticity value so that we can fit all of the
labels into a single plot. What you end up with should look as follows, such that the
labels are now readable.
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Step 4) Add letter labels for each subplot. Similar to what we did in the previous step lets
create individual labels for each subplot. In each case we will name our subplots after the stations
the data were recorded at. Make your labels: (a) CCP and (b) RES, and make them 12 point
font. Align the labels along the left plot edge. After this step your plot should look like:
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Step 5) Choose line weight and color for lines.

e Notice that if we try to select an individual line all lines get selected. To be able to select
a single line: (1) Select a group of lines then, (2) Select Object > Clipping Mask ->
Release. Now note that you can select individual lines.

o Notice that if we select one of the thick black lines that it has a line weight of 5 points,
which is stated in the Appearance window as Stroke: 5 pt
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o Let’s make the stroke smaller. The Color window allows us to change the line’s Weight
under the Stroke tab. Let’s change the Weight to 3 points:

J = Stroke \Gradient\l’ransparency‘\@l
wieight: 243 pt | = [=
fiter: Limit: 5 = elele

|_ [rashed Line
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e In this case, the thin red, green, and blue lines are essentially the same measurement.
Here we have made the decision to make these three lines the same thickness and the
color to be a shade of gray. Select the three lines. Note another common problem that
now occurs. These lines are still part of a compound path. You can see this by looking at
the Appearance window. It shows: Compound Path and Mixed Appearance.
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e We can correct this problem by selecting Object > Compound Path - Release.
e Now, we can change the color in the Color window for the lines. Let’s make each line

0.5 pt thick (modify the Stroke) and in the Color Window Choose an RGB color of R =
G =B =102. Your plot should now look like:

5(a)(?CP — - R

o Lastly, let’s select the dashed blue line. Let’s make the Stroke = 2 pt. and the color the
same as the last line R = G = B = 102. | don’t like the current dashed line appearance so
under the Stroke tab let’s change the dashed line to dash = 8 pt, gap = 2 pt, dash = 3 pt,

gap =2 pt.
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o Doing these steps to both plot panels we should now have an image that looks like this:
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Step 6) Final adjustments to position and size.

During our process of making our axis labels big enough for a human to read them we managed
to make our overall figure larger than our guide box. Hence, at some point (it may actually have
been better to do this earlier on — but better now than never) we need to go back and scale our
figure to ensure it all fits in the box. You should know how to do this by now — so go ahead and
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do it! You should end up with something that looks like the following — noting that your font
sizes should still be 12 and 10 in this example.
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Step 7) Add a figure legend.

At last we can’t just draw lines on a plot and not give a legend describing what they are. You can
easily do this by drawing short lines of the same style as in your figure and adding text next to
them. Do so as in the next image:
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Step 8) Final touches.

Now, all that’s left are some final touches to make sure the journal editors don’t screw things up
too much.

o First of all, remove the layer with the bounding box. The easiest way to do this is to
select the layer and hit the trash icon in the lower right corner:
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o Finally, I always like to add a label at the bottom stating:

i.  Figure Number

ii.  Authors Names
iii.  Should the figure Span a single column or Span two columns
iv.  Black & White or Color

Why you may ask? Once again — there is nothing worse than spending a year or so of your life
working on a research project, produce very elegant figures and illustrations, pay thousands of
dollars for the publication, and then have the figure get screwed up when it goes to print. It has
never happened to me personally, but | know people to whom it has happened. Take my word for
it, it isn’t desirable.

Our final figure now looks pretty acceptable. Here it is:
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4. A Gallery of Good Figures

In wrapping up this lecture, here are a few example figures that were done entirely in Illustrator.
The idea here is just to give you some ideas of what can be done.

Cartoons

Sometimes after you’ve put together your conclusions and final model it’s easiest to demonstrate
this with a cartoon drawing. Here are two exceptional examples drawn almost entirely in Adobe

Ilustrator.
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Fig. 4. An H,0-rich lens underplating the 410-km discontinuity in cross-section view, relative to the East
Pacific Rise (EPR), South American continent (SAm) and Mid-Atlantic Ridge (MAR). Trench migration
contributes to the hydrated wadsleyite lens evolution, the base of which is detected in our study. The

multiplicity of reflectors near 410- and 660-km depths may be explained by partial melt at the 410-km
boundary and by the presence of akimotoite below the 660-km discontinuity.

From: Schmerr, N., Garnero, E., (2007), Upper Mantle Discontinuity Topography from Thermal
and Chemical Heterogeneity, Science, 318, 623-626.
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Fig. 1. Tomographically derived (43) high and low seismic shear velocity variations in Earth’s mantle
(blue and red, respectively) are shown in an equatorial cross section (right) viewed from the south, along
with an enlarged panel (left) depicting several seismic findings in the D" region. A large low-shear-velocity
province (LLSVP) is found beneath the Pacific Ocean and Africa, and has high density (p) and temperature
(), with sharp sides between LLSVP low velocities (—dV/s) and surrounding mantle. A pair of seismic
reflectors seen beneath subduction as well as within the LLSVP is consistent with a double crossing of the
perovskite (Pv) to post-perovskite (pPv) phase transition (yellow dashed lines), which locally elevates shear
velocity (+dVs). Ultralow-velocity zone (ULVZ, yellow) material sits atop the CMB and can be swept around
in lateral currents, possibly relating to chemical reactions between the mantle and core. The spin
transition zone (STZ) centered near 1500 km depth represents a change in the spin state of Fe?* to Fe®*
and may also affect lower-mantle densities and velocities (44, 45).

From: Garnero, E.J., and A. K. McNamara, Structure and dynamics of Earth’s Lower Mantle,
Science, 320, 626-628, 2008.




Geophysical Computing L18-14

6. Homework

1) Everyone should at this point have some figure they have created that is related to their
research. Format it in Adobe Illustrator such that it looks presentable for publication. For this
homework please provide a print out of your final illustration to me.



